We use Capture to record exploratory test sessions. A number of my team members who are on Windows machines cannot "capture" a test session. When they create a session they cannot start it
When they log in to JIRA they see the following error:
com.thoughtworks.xstream.io.StreamException: : only whitespace content allowed before start tag and not \u0 (position: START_DOCUMENT seen \u0... @1:1)
Hi Chris,
We have an article titled Only whitespace content allowed before start tag when trying to view project within JIRA Software that may help with this:
Cause
JIRA Software's configurations are stored as XML within the database. With that, if the XML is invalid, it can result in the above.
For example, a normal entry may look like this:
id | propertyvalue ------------------------ 10399 | <map> : <entry> : <string>GH_gh.issue.releasedVersionHistoryField</string> : <string>customfield_10006</string> : </entry> : <entry> : <string>FIX_VERSION_SYNCHER</string> : <boolean>false</boolean> : </entry> : <entry> : <string>gh.configuration.rapidboard.scrum</string> : <boolean>true</boolean> : </entry> : </map>
Problematic entry:
id | propertyvalue ------------------------ 10399 | ![CDATA[<map> : <entry> : <string>GH_gh.issue.releasedVersionHistoryField</string> : <string>customfield_10006</string> : </entry> : <entry> : <string>FIX_VERSION_SYNCHER</string> : <boolean>false</boolean> : </entry> : <entry> : <string>gh.configuration.rapidboard.scrum</string> : <boolean>true</boolean> : </entry> : </map>]]
Workaround
Remove the problematic entry from both the propertyentry and propertytext tables.
back up your data first.
Resolution
back up your data first. Only attempt this if you are comfortable with database administration.
Identify the problematic XML:
Identify the Project's ID:
select * from project;
Identify the Project's configurations (this may return quite a few results):
select * from propertytext where ID in (select ID from propertyentry where property_key = 'GREENHOPPER%XXXXX');
- With the list of results, check the XML data. Note that this may return a large list of results
Once the problematic XML is found, update the entry with the proper format
Take a look at the knowledge base article and go through the steps and let me know if that helps. If not we'll go from there.
Cheers,
Branden
Thanks! we are looking into this I will let you know if the advice helped!
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